Zoom G2.1u Effects processor not working with power adapter.

Discussion in 'Guitar Gear Talk Forum' started by yashodhan92, Jan 6, 2009.

  1. yashodhan92

    yashodhan92 New Member

    I recently bought a new Zoom G2.1u effetcs processor from singapore. A problem has cropped up suddenly it works with batteries but not with the zoom power adapter which i bought? i also tried some other adapters but they too not working? what do I do now? Its really urgent.! I bought an original Zoom Adapter of 300mA, i tried a 1000mA adapter of some XYZ brand that seems to work. But is it advisable to use that?
  2. amit25

    amit25 New Member

    buy an adjustable adapter and put the volt between 9v and 12v then it ll work I got a second hand processor for a week it worked
  3. thepacifist2013

    thepacifist2013 V.I.P Member

    Dunno about the Zoom G series, but I have a Zoom 707II up for sale which ONLY works on 1000mA adapters. I don't know why this happens but it happens. Another guy had the same problem with Zoom707II and when I advised him to fire up through a 1000mA adapter, it worked.

    I don't know why it happens, since the proc rated amperage is 300mA. I wouldn't suggest that to you for fear of frying the proc. But yeah, this happens.

    @amit25 : I tried upping the voltage and that didn't work with mine.
  4. yashodhan92

    yashodhan92 New Member

    kk thanks i'll use it with the 1000mA 1 then.
  5. thepacifist2013

    thepacifist2013 V.I.P Member

    Do test it man! Don't blame me if it pops open all fried sunny-side up.
  6. yashodhan92

    yashodhan92 New Member

    lol.. and how much u selling your washburn for?
  7. thepacifist2013

    thepacifist2013 V.I.P Member

    The guitar's sold dude. I'm gonna update my sig.

Share This Page