Problem with my Pod XT live

Discussion in 'IGT Soundtrack - Your Band, Your Gig, Your Music' started by d_ist_urb_ed, Dec 25, 2007.

  1. d_ist_urb_ed

    d_ist_urb_ed Genuflect b*tches!

    I have a Pod XT live which is not powering up. The last i used it was a few days ago to record and then i tried to switch it on today. I checked the sockets and the converters and they're working fine. So then i am led to believe that this might be a problem with the power adapter. Is there any way to confirm this? Other than ordering a new one? Also god forbid if it's not the adapter and it's the processor that has a problem, what are my options? I live in Hyderabad.
     
  2. sukrut

    sukrut God Guitarist

    wrong forum dude.........
    try the computer or the guitar gear forum..........
     
  3. satch_attack

    satch_attack New Member

    well..you could check the polarity ..
     
  4. d_ist_urb_ed

    d_ist_urb_ed Genuflect b*tches!

    Oh damn, i meant to post it in the Guitar gear forum. Oh well, and satch, how do i check it's polarity?
     
  5. satch_attack

    satch_attack New Member

    As far as i know ...its regarding the adapter .you get these adapters with interchangable polarities ..you have to remove the plug which goes into your processor n kinda flip it so that you interchange the plus n minus ..i happened to my zoom ..No matter what you do ...the processor simply refused to turn on ..after interchanging the polariy ..it worked ..Its a rather "Le mans" kinda explanation ..
     
  6. d_ist_urb_ed

    d_ist_urb_ed Genuflect b*tches!

    "n kinda flip it", how do i do that?
     
  7. thehundredthone

    thehundredthone New Member

    Did you try powering something else with the adapter?
     
  8. d_ist_urb_ed

    d_ist_urb_ed Genuflect b*tches!

    Well it's an output of 9V, so i dont know which device to test it with exactly.
     
  9. alpha1

    alpha1 I BLUES!

    Fit in battery.
    If it works, then your POD is alive.

    Else
    Check the voltage required by POD, and fit in another adapter with same voltage rating, and reversible polarity.
    If the POD works, then your adapter has gone bust, or
    Else
    you are gone bust.
     

Share This Page